Linux下安装VIM 7.4

安装VIM需要的工具,因为VIM是开源的代码,需要编译安装,

所以要求Linux环境安装过GCC,安装GCC请见 CentOS环境通过ISO镜像安装GCC

下载VIM 7.4 for UNIX

下载地址:ftp://ftp.vim.org/pub/vim/unix
FTP到/usr/目录下解压
[root@localhost usr]# tar - xvjf vim-7.4.tar.bz2 得到 vim74源码文件夹

编译安装程序

- 配置编译选项
- [root@localhost vim74]# ./configure --prefix=/usr --mandir=/usr/share/man --enable-multibyte - 编译 - [root@localhost vim74]# make - 安装 - [root@localhost vim74]# make install

### 安装问题解决方法:

我在RHEL环境下安装VIM 7.4在make时,报错如下:
You need to install a terminal library; for example ncurses.
Or specify the name of the library with –with-tlib.
是因为缺少ncurses
在ISO镜像Packages中找到ncurses-devel-5.7-3.20090208.el6.x8664.rpm
yum -y install ncurses-devel-5.7-3.20090208.el6.x86
64.rpm
重新./configure、make、makeinstall
安装成功!

comments powered by Disqus